未来往事
在编译安装mysqlsla遇到如下错误提示,该错误缺少依赖的包文件所致。解决方法如下:

错误提示一:
[root@monitor mysqlsla-2.03]# perl Makefile.PL   //perl脚本检查包依赖关系
Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at Makefile.PL line 2.
BEGIN failed--compilation aborted at Makefile.PL line 2.

缺少perl-ExtUtils-MakeMaker依赖包,安装即可

[root@localhost mysqlsla-2.03]# yum install perl-ExtUtils-MakeMaker perl-ExtUtils-CBuilder

错误提示二:
[root@monitor opt]# mysqlsla -lt slow2.log
Can't locate Time/HiRes.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/local/bin/mysqlsla line 2095.
BEGIN failed--compilation aborted at /usr/local/bin/mysqlsla line 2095.

缺少perl-Time-HiRes依赖包,安装即可

[root@monitor mysqlsla-2.03]# yum install perl-Time-HiRes  
作者:Rinald @『未来往事 | 记录生活,存储回忆!
原文地址:http://fity.cn/post/319/
本站采用「署名 4.0 国际(CC BY 4.0)」创作共享协议。通俗地讲,只要在使用时署名,那么使用者可以对本站所有原创内容进行转载、节选、混编、二次创作,允许商业性使用。除非在文章正文内单独说明,本站欢迎各种形式的转载。互联网技术更新很快,本站很多文章都具有实效性,我会及时更新原文,但转载的文章无法通知更新。为了不给读者造成困惑或误导,请大家在转载时保留此出处信息。
发表评论
  昵称 [注册]
  密码 (游客无需密码)
  网址
  电邮(电子邮件地址不会被公开, 仅用于接收评论回复提醒使用)
OpenID登入 权限选项 表情